Post

1 follower Follow
1
Avatar

Korean language problem

Dear, 

I have written a great volume of Rstudio script documents while learning different statistical techniques for more than one year. I have written those scripts half in English and half in Korean (especially when I needed extra clarification in my own language, etc). 

There has been no problem writing and reading these documents until this morning when the error message below started to pop up: 

"Not all characters in C:/Users/NS130717/Dropbox/1R/1code/cfa.doom.R could be decoded using CP949."

So I tried "save with encoding" and "reopen with encoding" using all sorts of different encodings including UTF-8 and all other Korean related encodings. But nothing worked. Instead, while trying these methods, my entire scripts got messed up and I cannot read my writing in Korean anymore because they now appear weird as follows: 

??????? ?????????????????
Marker variable ??娘??

#html???????? ???? ????, plot?????? ???? ???? ?????????? ?????? ??????.
#???? markdown folder?? 1.Rmd?????? ?? html?? ?????? ???????????? 1?? ??????????.
#1.Rmd?? ?????? ???? ???? html?????? ???? ?????? ???????? ?????? ?????? ?????????? ??????.
#markdown?????? ?????????? ?????? ?????? ???? ?????? ????????????.

There should be a way to see my Korean writings in the documents. I searched the web for a half day, to no avail. 

Any help would be much appreciated. 

 

Ilhong 

Ilhong Yun