Post

13 followers Follow
4
Avatar

Not installing in Ubuntu 16.10

I am not being able to install Rstudio latest version on Ubuntu 16.10. Some libraries are missing from offical repositories. 

 

Any suggestion?

RAFAEL DETTOGNI GUARIENTO

19 comments

3
Avatar

gstreamer-0.1.0 has been deprecated in 16.10. But you can grab the two missing dependencies from 16.04's repo.

Download and installl 16.04's version of libgstreamer-0.1.0 from https://launchpad.net/ubuntu/+source/gstreamer0.10 and libgstreamer-plugin-base from https://launchpad.net/ubuntu/+source/gst-plugins-base0.10/+index

(go to xenial, click the little triangle on the left of the row, then download the deb for your architecture)

Now rstudio should install.

P.S A bug should be filed against either Ubuntui or rstudio.

ben 3 votes
0
Avatar

@ben

Thanks a lot.

I am new to Ubuntu. So I installed Ubuntu 16.04 and then Rstudio, finally I upgraded to Ubuntu 16.10.

I will try the beta version latter.

johnmy 0 votes
0
Avatar

Hi,

1.0.102 apparently doesn't work. It installs but won't start. Still asks for gstreamer-0.1.0. Maybe the higher one works? But you can definitely install the two gstreamer-0.1.0 packages and it will work.

 

P.S Since you are new to Ubuntu, just a suggestion, you don't need to upgrade whenever there is a new release. !6.04 is supported for 5 years, 16.10 is supported for only 9 months and it is kind of a beta.

ben 0 votes
0
Avatar

For me, .106 doesn't install because the package still depends on libgstreamer-0.10. Maybe .102 was a one-off build? That installs, but possibly still linked against the old gstreamer despite the package dependency being moved forward. For me, ldd lists the dependency differently for the symlink in /usr/bin and the actual executable. The actual executable is listed as 0.10 and indeed fails to run. After clearing the ld cache I still get an inconsistent (and ultimately not working) result:

rstudio: error while loading shared libraries: libgstreamer-0.10.so.0: cannot open shared object file: No such file or directory

Sam Brightman 0 votes
0
Avatar

Same problem for me in 16.10. I can install 1.0.102, but can't launch it:

rstudio: error while loading shared libraries: libgstreamer-0.10.so.0: cannot open shared object file: No such file or directory

Robert McDonald 0 votes
2
Avatar

Is there a fix for this yet?  As the other posters have said the newer packages still depends on deprecated versions of libgstreamer which Ubuntu will not install from the main repo.

Matthew Bashton 2 votes
0
Avatar

In addition to following the instructions on Mike Williamson's blog post to install Gstreamer0.10-0, I also had to install the dependency libjpeg62.

sudo apt-get install libjpeg62

John Blischak 0 votes
0
Avatar

@Jonathan by chance I needed to reinstall rstudio today so I tried the preview. The dependency is still there.

 

richardc@richardc-HP-ProBook-4515s:~/Downloads$ sudo dpkg -i rstudio-1.0.147-amd64.deb
Selecting previously unselected package rstudio.
(Reading database ... 155365 files and directories currently installed.)
Preparing to unpack rstudio-1.0.147-amd64.deb ...
Unpacking rstudio (1.0.147) ...
dpkg: dependency problems prevent configuration of rstudio:
rstudio depends on libjpeg62; however:
Package libjpeg62 is not installed.
rstudio depends on libgstreamer0.10-0; however:
Package libgstreamer0.10-0 is not installed.
rstudio depends on libgstreamer-plugins-base0.10-0; however:
Package libgstreamer-plugins-base0.10-0 is not installed.

dpkg: error processing package rstudio (--install):
dependency problems - leaving unconfigured
Processing triggers for shared-mime-info (1.7-1) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu1.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Errors were encountered while processing:
rstudio
richardc@richardc-HP-ProBook-4515s:~/Downloads$

Richard Crawley 0 votes
0
Avatar

@Richard It looks like you downloaded the .deb intended for older Debian releases. The .deb for Debian 9 has "xenial" in the file name (named after the Ubuntu release with which it's built). 

Jonathan.

Jonathan McPherson 0 votes
0
Avatar

@Jonathan: It is very easy to overlook the Xenial version, especially since it is listed separately from the other Ubuntu/Debian versions, and also because the others explicitly say "Ubuntu 12.04+", which seems as if it should include 16.04+.

My suggestion is to change the order in which the releases are listed. If possible, it would also be helpful to change the name of the Ubuntu releases compatible only with with 12.04 - 15.10. 

Robert McDonald 0 votes
0
Avatar

I tried installing the preview release 1.0.150 on Ubuntu 17.04, but it failed due to the missing dependency libssl1.0.2.

I unheld the gstreamer packages, downloaded the preview release for Ubuntu 16.04+, and attempted to install it with dpkg.

$ sudo apt-mark unhold libgstreamer0.10-0 libgstreamer-plugins-base0.10-0

Canceled hold on libgstreamer0.10-0.
Canceled hold on libgstreamer-plugins-base0.10-0.
$ wget https://s3.amazonaws.com/rstudio-dailybuilds/rstudio-xenial-1.0.150-amd64.deb

$ md5sum rstudio-xenial-1.0.150-amd64.deb
f24f93cdea6ce910f5af119b3175bb67  rstudio-xenial-1.0.150-amd64.deb

$ sudo dpkg -i rstudio-xenial-1.0.150-amd64.deb

(Reading database ... 421508 files and directories currently installed.)
Preparing to unpack rstudio-xenial-1.0.150-amd64.deb ...
Unpacking rstudio (1.0.150) over (1.0.143) ...
dpkg: dependency problems prevent configuration of rstudio:
 rstudio depends on libssl1.0.2; however:
  Package libssl1.0.2 is not installed.

dpkg: error processing package rstudio (--install):
 dependency problems - leaving unconfigured
Processing triggers for shared-mime-info (1.8-1) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Processing triggers for bamfdaemon (0.5.3+17.04.20170406-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu5) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Errors were encountered while processing:
 rstudio

Doing some investigating, I don't think libssl1.0.2 exists in the Ubuntu repositories. There is a library called libssl1.0.0, and its latest version is 1.0.2g-1ubuntu11.2. I have the latest version of libssl1.0.0 installed.

$ apt list | grep libssl

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libssl-dev/zesty-updates,now 1.0.2g-1ubuntu11.2 amd64 [installed]
libssl-doc/zesty-updates,zesty-updates,now 1.0.2g-1ubuntu11.2 all [installed,automatic]
libssl-ocaml/zesty 0.5.2-2 amd64
libssl-ocaml-dev/zesty 0.5.2-2 amd64
libssl1.0-dev/zesty-updates 1.0.2g-1ubuntu11.2 amd64
libssl1.0.0/zesty-updates,now 1.0.2g-1ubuntu11.2 amd64 [installed]
libssl1.0.0-dbg/zesty-updates 1.0.2g-1ubuntu11.2 amd64
libsslcommon2/zesty 0.16-9ubuntu8 amd64
libsslcommon2-dev/zesty 0.16-9ubuntu8 amd64

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 rstudio : Depends: libssl1.0.2 but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

John Blischak 0 votes
0
Avatar

@Jonathan While I could not install the preview release (v1.0.150) on Ubuntu 17.04 because of the missing libssl1.0.2 dependency (full details in my previous post), I was able to install the daily build from 2017-07-20 08:21:09 (v1.1.310):

$ wget https://s3.amazonaws.com/rstudio-dailybuilds/rstudio-xenial-1.1.310-amd64.deb
$ md5sum rstudio-xenial-1.1.310-amd64.deb
a50e296a44c063026bef0d3c234f0cef  rstudio-xenial-1.1.310-amd64.deb
$ sudo gdebi rstudio-xenial-1.1.310-amd64.deb

John Blischak 0 votes
0
Avatar

while there is a new ubunte / debian version without gstreamer 0.10 dependency, there is none for opensuse tumbleweed, which also deprecated gstreamer 0.10.

Would be very nice of you guys, if you could provide a gstreamer 1.x version for opensuse. There is no need for the 0.10 version anymore. Some more detail, if needed:

opensuse 12.3 had gstreamer 1.05

13.1 had 1.0.10

13.2 had 1.4.3

42.1 had 1.4.5

42.2 had 1.8.3

42.3 also 1.8.3

Thomas 0 votes