Post

4 followers Follow
5
Avatar

Ctrl+y behaviour recently changed - from "redo" to "paste"

The ctrl+y behaviour inside the editor has always been "redo" (ctrl+z and ctrl+y are how I always work!)

 

With the new version of RStudio, it seems to have been changed to "paste" by default.  On Windows machines, ctrl+y generally means redo, I strongly vote to change it back.  

Dean Attali

3 comments

0
Avatar

I strongly agree with this because:

  • To have Ctrl-Y mapped to redo is standard, for example Sublime text has Ctrl-Y mapped to redo. Also Rstudio used to have Ctrl-Y mapped to Redo until recently.
  • There is already an emacs mode in R-studio, so if you want emacs, then you could use that. The point of the "default" keybindings I think should be to be "standard", that is, to follow the rule of least surprise.
  • To Yank when you want to Redo is super surprising! It not only pastes some text you certainly not wanted to see, it also breaks the the undo/redo chain so that you will never be able to redo what you wanted to redo.

:)

Rasmus Arnling Bååth 0 votes
Comment actions Permalink
0
Avatar

Yeah, this is a serious problem for me. I don't want to remap my brain and hand to use CTRL+SHIFT+Z just for this IDE alone.

For what it's worth, they talked about fixing it shortly after the OP:

  • Pierre GrammeMarch 30, 2016 10:28

    Hi Kevin and the team,

    Maybe a dumb question: on Ubuntu, how can I differentiate between Ctrl and Cmd keys?

    I would like to use the standard Ctrl+Y shortcut for "Redo". But when I type it, it gets interpreted as "Insert Yanked Text" (as I guess from the shortcut quick ref).

    Can I disable this shortcut for "Insert Yanked Text" even if it's not listed in the dialog box? Can I assign Ctrl+Y to "Redo"?

    Thanks
    Pierre

  • Kevin UsheyMarch 30, 2016 13:47

    Hi Pierre,

    This is an unfortunate limitation in the current version of RStudio, as the various 'yank' commands are hard-coded to these bindings (and have been for some time). We plan to resolve this for the next release.

    Thanks,
    Kevin

I have no idea what they consider to be a "release," but it's been a while since March. It would be nice to see an update posted here if/when they fix this.

Frank Erickson 0 votes
Comment actions Permalink
1
Avatar

This appears to be fixed in the latest version of R (v. 1.0.44).

By fixed I mean you can go into keyboard shortcuts and unbind Ctrl-Y from "Paste Last Yank". Once that is done Ctrl-Y automatically maps to the redo command.

Mark Rucker 1 vote
Comment actions Permalink