Post

4 followers Follow
4
Avatar

R Studio Server "session hadabend"

I am system administrator supporting about 50 scientists working with R Studio. On a regular basis they complain about "RStudio [Server] crashing". Sure enough, I see the following message in the log (side note, it's a very bad idea to write application messages to the system message log - but you probably know that):

Apr 4 13:22:52 servername rsession-username[28142]: ERROR session hadabend; LOGGED FROM: core::Error<unnamed>::rInit(const r::session::RInitInfo&) /root/rstudio/src/cpp/session/SessionMain.cpp:1373

The user gets an error popup saying that R Session disconnected. No errors in Apache logs.

Any ways to troubleshoot this? Happens couple times a day (across 50 people, not twice a day for each). We are running RStudio 0.96 and R 2.15.2

Ian Pylvainen

4 comments

0
Avatar

Felix,

Thanks for reporting this. I manage our own internal servers and this does happen on occasion often from R itself crashing, or occasionally RStudio crashing. Although in most cases it's harmless, I understand the desire to track this down and understand what is going on. Really the only way to investigate this would be to turn on core dumps (this is what we do).

To get core dumps working you need to create a directory with appropriate permissions and change the kernel core pattern:

http://www.randombugs.com/linux/core-dumps-linux.html
http://stupefydeveloper.blogspot.com/2008/10/gdb-examining-core-dumps.html
http://www.novell.com/support/viewContent.do?externalId=3054866&sliceId=1

We can't really provide too much help on how to do this for your system, but the above links should point you in the right direction.

Josh

Ian Pylvainen 0 votes
Comment actions Permalink
0
Avatar

I am getting this error too: any updates on this case?

02 Mar 2017 20:04:30 [rsession-robinsam] ERROR session hadabend
 
RHEL 7
Clustered configuration of RStudio Server Pro
Version 1.0.44 – © 2009-2016 RStudio, Inc.
Will Westing 0 votes
Comment actions Permalink
0
Avatar
rm -r .rstudio
sudo rstudio-server suspend-all

worked for me. I first also moved .RData to a separate folder and upgraded the rstudio server. However, still the problem remained.

Kristian Persson Hodén 0 votes
Comment actions Permalink