Post

4 followers Follow
0
Avatar

Unable to Initialize the JIT

We recently started seeing this error when launching RStudio. It seems to be random. (R software opens without issue)

Steps I have taken:

  1. I have uninstalled all versions of R and RStudio. Reboot, then installed both newest versions from the websites under my admin account (run as admin), as well as under the users account using my admin credentials.
  2. I have tried older versions of both software.
  3. I have given “everyone” full control of the R folder and RStudio folder listed under Program files.
  4. I have given a specific user full control of the R folder and RStudio folder listed under Program Files. (This did actually work for one user, but no others)
  5. I have installed it on my PC and on 2 spare PC’s we have in our dept. (installed as admin, ran under non-admin account). It works without issue on all of the machines.
  6. One of the other techs in my dept installed them on his machine and he receives this error when launching RStudio. 

The latest update of RStudio was released on 07/20, but it appears it is affecting older versions as well. (at least after installing the latest version, and then trying to uninstall it and install an older version)

Joshua Spiker

3 comments

0
Avatar

Hi Joshua,

Thanks for the bug report. Unfortunately, I'm not exactly sure what could be causing this -- it's possible that some code that R is attempting to run on startup is now failing, and that's causing the crash.

Is it possible that there is a custom .Rprofile or .Renviron that could be influencing startup, and this is causing issues?

Thanks,
Kevin

Kevin Ushey 0 votes
Comment actions Permalink
0
Avatar

Here is the latest update. I found this is an issue if:

1. The user isn't an admin on their system.

2. They were running an older version of RStudio and/or R Software. (I wasn't able to determine which is the issue)

If it's a brand new system, then the newest version works without an issue.

If it's a system that had an older version of software on it before, you upgrade both pieces of software, and a new user who has never logged into the system before logs in, then it works without issue for that user, but not previously logged in users.

I tried removing any instance of R and RStudio from the user's profile folder that I could find and then had them log in. This did not resolve the issue.

ANSWER!!!!!!!!!

I found what would work. I delete the user's profile entirely. I then have them login and run R and RStudio. Both work successfully.

 

My Assumption is there is something in the registry that is causing this issue, but I am not sure. For now, we are just using the working method.

Joshua Spiker 0 votes
Comment actions Permalink
0
Avatar

I was running into the same error when trying to run R-3.4.1. I have a custom list (slimmed down) of packages I use. The error was fixed by also installing the 'compiler' package which has become a part of the "loaded via a namespace (and not attached):" list with 3.4. If this is your issue as well, I would guess one of the packages you upgraded after July 20th calls it causing the error no matter which version of R you run.

Scott Wilster 0 votes
Comment actions Permalink